summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 16:01:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:58:09 +0200
commit1e6d64c2dc42c699678534eb2a0e9cfc6a09ce61 (patch)
treeeb65cabc227a71743c3d0fa9ffe2894244d1243a
parent00eea05ab893d79a9f48877cd0774e1f010d6bba (diff)
downloadguix-1e6d64c2dc42c699678534eb2a0e9cfc6a09ce61.tar.gz
gnu: Add rebar3-raw-deps.
* gnu/packages/erlang.scm (rebar3-raw-deps): New variable.
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 3350005277..76e386baf2 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -630,3 +630,20 @@ build configuration work.  @code{rebar3} also provides dependency management,
 enabling application writers to easily re-use common libraries from a variety
 of locations (git, hg, etc).")
     (license license:asl2.0)))
+
+(define-public rebar3-raw-deps
+  (package
+    (name "rebar3-raw-deps")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri "rebar3_raw_deps" version))
+       (sha256
+        (base32 "1pzmm3m8gb2s9jn8fp6shzgfmy4mvh2vdci0z6nsm74ma3ffh1i3"))))
+    (build-system rebar-build-system)
+    (home-page "https://github.com/soranoba/rebar3_raw_deps")
+    (synopsis "Rebar3 plugin for supporting \"raw\" dependencies")
+    (description "This plugin provides support for handling non-OTP
+applications as a dependent libraries.")
+    (license license:expat)))