summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:21:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:06 +0300
commit24848450190effbf08204df6b926dea59e6873ce (patch)
tree4f48fbf275e91c7bea16ebf56bc348b1414b5a51
parentb3038b3826e4b4a6fc1e479ec4cc20a2263866f7 (diff)
downloadguix-24848450190effbf08204df6b926dea59e6873ce.tar.gz
gnu: Add rust-same-file.
* gnu/packages/crates-io.scm (rust-same-file): New variable.
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3589e8291a..5b5b12e392 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1138,6 +1138,30 @@ rust-lang/rust integration.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-same-file
+  (package
+    (name "rust-same-file")
+    (version "1.0.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "same-file" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "08a4zy10pjindf2rah320s6shgswk13mqw7s61m8i1y1xpf8spjq"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+      (("rust-winapi-util" ,rust-winapi-util))))
+    (home-page "https://github.com/BurntSushi/same-file")
+    (synopsis "Determine whether two file paths point to the same file")
+    (description
+     "This package provides a simple crate for determining whether two file
+paths point to the same file.")
+    (license (list license:unlicense
+                   license:expat))))
+
 (define-public rust-scoped-tls
   (package
     (name "rust-scoped-tls")