summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:26:05 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:46 +0200
commit2b474f45c1c4b9c3b512c713ac25f01cea5854bb (patch)
tree0a87d73923e67a31c1a0ea4ebe683002887116e9
parent8680f3fbb7fa26ebab9bd6287ee5d915c6890753 (diff)
downloadguix-2b474f45c1c4b9c3b512c713ac25f01cea5854bb.tar.gz
gnu: Add erlang-hex-core.
* gnu/packages/erlang.scm (erlang-hex-core): New variable.
-rw-r--r--gnu/packages/erlang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 596de6d608..ed6100023f 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -360,6 +360,32 @@ of reusable Erlang components.")
 arguments using the GNU getopt syntax.")
     (license license:bsd-3)))
 
+(define-public erlang-hex-core
+  (package
+    (name "erlang-hex-core")
+    (version "0.8.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri "hex_core" version))
+       (sha256
+        (base32 "06p65hlm29ky03vs3fq3qz6px2ylwp8b0f2y75wdf5cm0kx2332b"))))
+    (build-system rebar-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "rebar3" "as" "test" "proper")))))))
+    (inputs
+     (list erlang-proper rebar3-proper))
+    (home-page "https://github.com/hexpm/hex_core")
+    (synopsis "Reference implementation of Hex specifications")
+    (description "This package provides the reference implementation of Hex
+specifications.")
+    (license license:asl2.0)))
+
 (define-public erlang-parse-trans
   (package
     (name "erlang-parse-trans")