summary refs log tree commit diff
diff options
context:
space:
mode:
authorJens Mølgaard <jens@zete.tk>2019-07-18 19:54:38 +1200
committerLudovic Courtès <ludo@gnu.org>2019-07-27 01:00:03 +0200
commit40c4c0058f64ee10db202560789f100cfceb4954 (patch)
tree1742f16b82ab86760b2d64ca53e10aa7936647b6
parent9f0ae848e274248e235c200a0981aed663cb16bc (diff)
downloadguix-40c4c0058f64ee10db202560789f100cfceb4954.tar.gz
gnu: Add emacs-ox-pandoc.
* gnu/packages/emacs-xyz.scm (emacs-ox-pandoc): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df2c90272f..2315d0f3de 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16828,3 +16828,28 @@ which should give broad compatibility.  It should also be relatiely easy to
 convert the resulting @code{.epub} to a @code{.mobi} file.  Needs a working
 zip utility (default is @code{zip}).")
     (license license:gpl3+)))
+
+(define-public emacs-ox-pandoc
+  (package
+    (name "emacs-ox-pandoc")
+    (version "20180510")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/kawabata/ox-pandoc.git")
+                    (commit "aa37dc7e94213d4ebedb85c384c1ba35007da18e")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0iibxplgdp34bpq1yll2gmqjd8d8lnqn4mqjvx6cdf0y438yr4jz"))))
+    (build-system emacs-build-system)
+    (inputs
+     `(("pandoc" ,ghc-pandoc)))
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-ht" ,emacs-ht)))
+    (home-page "https://github.com/kawabata/ox-pandoc")
+    (synopsis "Org exporter for Pandoc")
+    (description "@code{ox-pandoc} is an exporter for converting Org-mode
+files to numerous other formats via Pandoc.")
+    (license license:gpl3+)))