summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-10 23:29:39 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-10 23:41:33 +0100
commit45fef894eb5b39029633cd0cd907e8ce8c5ab379 (patch)
tree5d8a6f20f2777b736eab4aa17f0b05824e155a39
parent5ae5932b2f84b58f51f220f5d3103f96a8ef09e8 (diff)
downloadguix-45fef894eb5b39029633cd0cd907e8ce8c5ab379.tar.gz
gnu: gnome-shell: Avoid top-level reference to inkscape.
Fixes <https://bugs.gnu.org/34806>.
Reported by Marius Bakke <mbakke@fastmail.com>.

* gnu/packages/gnome.scm (gnome-shell)[source](snippet): Remove
reference to INKSCAPE.  Instead, simply copy the SVG file to
data/theme.
[arguments]: Add 'convert-logo-to-png' phase.
[native-inputs]: Add INKSCAPE.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 12ce39cb4a..0344e42444 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5695,10 +5695,9 @@ properties, screen resolution, and other GNOME parameters.")
                    (copy-file #$(file-append %artwork-repository
                                              "/slim/0.x/background.png")
                               "data/theme/guix-background.png")
-                   (invoke #+(file-append inkscape "/bin/inkscape")
-                           "--export-png=data/theme/guix-logo.png"
-                           #$(file-append %artwork-repository
-                                          "/logo/Guix-horizontal-white.svg"))
+                   (copy-file #$(file-append %artwork-repository
+                                             "/logo/Guix-horizontal-white.svg")
+                              "data/theme/guix-logo.svg")
                    #t))))
     (build-system glib-or-gtk-build-system)
     (arguments
@@ -5711,6 +5710,11 @@ properties, screen resolution, and other GNOME parameters.")
              (invoke "make" "-C" "data"
                      "theme/gnome-shell.css"
                      "theme/gnome-shell-high-contrast.css")))
+         (add-before 'build 'convert-logo-to-png
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Convert the logo from SVG to PNG.
+             (invoke "inkscape" "--export-png=data/theme/guix-logo.png"
+                     "data/theme/guix-logo.svg")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out     (assoc-ref outputs "out"))
@@ -5741,7 +5745,8 @@ properties, screen resolution, and other GNOME parameters.")
        ("pkg-config" ,pkg-config)
        ("python" ,python)
        ("xsltproc" ,libxslt)
-       ("ruby-sass" ,ruby-sass)))
+       ("ruby-sass" ,ruby-sass)
+       ("inkscape" ,inkscape)))
     (inputs
      `(("accountsservice" ,accountsservice)
        ("caribou" ,caribou)