summary refs log tree commit diff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2022-06-15 15:06:07 +0200
committerClément Lassieur <clement@lassieur.org>2022-06-15 15:39:50 +0200
commit673983c9c6e86596abc9082e47319285674d7eda (patch)
treeb4b9a3bee695107e3aeeab37fe69f98445f0316e
parenta431d1dbc5a009ad852b55e2300465b49bdce362 (diff)
downloadguix-673983c9c6e86596abc9082e47319285674d7eda.tar.gz
gnu: emacs-lsp-mode: Update to 8.0.1-0.4aafe25.
* gnu/packages/emacs-xyz.scm (emacs-lsp-mode): Update to 8.0.1-0.4aafe25.
[arguments]: Add a 'fix-patch-el-files' phase.
-rw-r--r--gnu/packages/emacs-xyz.scm86
1 files changed, 47 insertions, 39 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 06f35d79e4..79e4ece40e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24930,45 +24930,53 @@ the standard @code{Dockerfile} file format.")
     (license license:asl2.0)))
 
 (define-public emacs-lsp-mode
-  (package
-    (name "emacs-lsp-mode")
-    (version "8.0.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/emacs-lsp/lsp-mode")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1a6jc9sxf9b8fj9h8xlv5k546bkzsy8j5nj19cfama389z0bzcsl"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:emacs ,emacs  ;need libxml support
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'move-clients-libraries
-           ;; Move all clients libraries at top-level, as is done, e.g., in
-           ;; MELPA.
-           (lambda _
-             (for-each (lambda (f)
-                         (install-file f "."))
-                       (find-files "clients/" "\\.el$")))))))
-    (propagated-inputs
-     (list emacs-dash
-           emacs-f
-           emacs-ht
-           emacs-hydra
-           emacs-markdown-mode
-           emacs-spinner))
-    (home-page "https://emacs-lsp.github.io/lsp-mode/")
-    (synopsis "Emacs client and library for the Language Server Protocol")
-    (description
-     "LSP mode is a client and library implementation for the Language Server
-Protocol.  This mode creates an IDE-like experience by providing optional
-integration with other popular Emacs packages like Company, Flycheck, and
-Projectile.")
-    (license license:gpl3+)))
+  (let ((commit "4aafe25e03ab7470b8d3c1cb326affa3c5e9930e")
+        (revision "0"))
+    (package
+      (name "emacs-lsp-mode")
+      (version (git-version "8.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacs-lsp/lsp-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01csz4vr3fg1q2py45mxj5j8bkvckn3daam1jafb2gg9gjc9bp7z"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:emacs ,emacs                 ;need libxml support
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'move-clients-libraries
+             ;; Move all clients libraries at top-level, as is done, e.g., in
+             ;; MELPA.
+             (lambda _
+               (for-each (lambda (f)
+                           (install-file f "."))
+                         (find-files "clients/" "\\.el$"))))
+           (add-before 'move-clients-libraries 'fix-patch-el-files
+             ;; /bin/ksh is only used on macOS, which we don't support, so we
+             ;; don't want to add it as input.
+             (lambda _
+               (substitute* '("clients/lsp-csharp.el" "clients/lsp-fsharp.el")
+                 (("/bin/ksh") "ksh")))))))
+      (propagated-inputs
+       (list emacs-dash
+             emacs-f
+             emacs-ht
+             emacs-hydra
+             emacs-markdown-mode
+             emacs-spinner))
+      (home-page "https://emacs-lsp.github.io/lsp-mode/")
+      (synopsis "Emacs client and library for the Language Server Protocol")
+      (description
+       "LSP mode is a client and library implementation for the Language
+Server Protocol.  This mode creates an IDE-like experience by providing
+optional integration with other popular Emacs packages like Company, Flycheck,
+and Projectile.")
+      (license license:gpl3+))))
 
 (define-public emacs-lsp-treemacs
   (package