summary refs log tree commit diff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-07-26 17:34:08 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:26 +0200
commit6e95e7d25f27fac4a5d017f6c2ea3e2d16c2f8c4 (patch)
treef96bbdf4f57efb6eb55b3eeab98d1c2d6c03bfd4
parentb7f47d243bc745c3a9e16de8afe29f3901ae3572 (diff)
downloadguix-6e95e7d25f27fac4a5d017f6c2ea3e2d16c2f8c4.tar.gz
gnu: Add go-github-com-leodido-go-urn.
* gnu/packages/golang.scm (go-github-com-leodido-go-urn): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c41ed0bb1a..bbd18cf932 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -487,6 +487,31 @@ jar struct to manage the cookies added to the cookie jar.")
       (home-page "https://github.com/aki237/nscjar")
       (license license:expat))))
 
+(define-public go-github-com-leodido-go-urn
+  (package
+    (name "go-github-com-leodido-go-urn")
+    (version "1.2.0")
+    (home-page "https://github.com/leodido/go-urn")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1d4g1vkhc1180l1n7q48vl84b27c7cziywml78cyijbcdz2f8vim"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/leodido/go-urn"))
+    (native-inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+    (synopsis "Parser for uniform resource names as seen on RFC 2141")
+    (description
+     "This package implements a parser for uniform resource names (URN) as
+specified by @uref{https://tools.ietf.org/html/rfc2141, IETF RFC 2141}.")
+    (license license:expat)))
+
 (define-public go-github.com-jessevdk-go-flags
   (package
     (name "go-github.com-jessevdk-go-flags")