summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 01:38:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 02:21:22 +0200
commit7dd57cc00e949dd414ed1c820d6452b2c9978184 (patch)
tree0e96dfb5a67a87524a8a27c3abab404bec7d9fce
parente45f0c79fbad86a9a181b8674219f385c8ea5504 (diff)
downloadguix-7dd57cc00e949dd414ed1c820d6452b2c9978184.tar.gz
gnu: hdparm: Fix cross-compilation.
* gnu/packages/linux.scm (hdparm)[arguments]: Use CC-FOR-TARGET.
Don't strip the binary during the build phase.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e60cc790e2..30420b013b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3821,10 +3821,13 @@ isolation or root privileges.")
                 "03z1qm8zbgpxagk3994lvp24yqsshjibkwg05v9p3q1w7y48xrws"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (let ((out (assoc-ref %outputs "out")))
-                      (list (string-append "binprefix=" out)
-                            (string-append "manprefix=" out)
-                            "CC=gcc"))
+     `(#:make-flags
+       (let ((out (assoc-ref %outputs "out")))
+         (list (string-append "binprefix=" out)
+               (string-append "manprefix=" out)
+               ,(string-append "CC=" (cc-for-target))
+               ;; Let Guix strip the binaries and not break cross-compilation.
+               "STRIP=true"))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))           ; no configure script