summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 10:21:32 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 10:21:32 +0200
commit94b8ad4490707369146eddd79d4f543238b4978e (patch)
tree50da0a8a5e53a05aec04008df3f14c0d68b89ff1
parent5aa68a9408e7af7dfb38abf48e499788fb7b0f82 (diff)
downloadguix-94b8ad4490707369146eddd79d4f543238b4978e.tar.gz
gnu: Add r-chipseeker.
* gnu/packages/bioconductor.scm (r-chipseeker): New variable.
-rw-r--r--gnu/packages/bioconductor.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 24b0e6a2fa..3359ce16cb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1055,6 +1055,54 @@ from Illumina 450k methylation arrays.")
 chromstaR package.")
     (license license:gpl3)))
 
+(define-public r-chipseeker
+  (package
+    (name "r-chipseeker")
+    (version "1.26.2")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "ChIPseeker" version))
+              (sha256
+               (base32
+                "1r197qwsriap6s6nb2p9j3521pjs2f0lgyzvppvlxj1531sa6g6z"))))
+    (build-system r-build-system)
+    (inputs
+     `(("r-knitr" ,r-knitr)))
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-boot" ,r-boot)
+       ("r-enrichplot" ,r-enrichplot)
+       ("r-iranges" ,r-iranges)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-genomicfeatures" ,r-genomicfeatures)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-gplots" ,r-gplots)
+       ("r-gtools" ,r-gtools)
+       ("r-dplyr" ,r-dplyr)
+       ("r-plotrix" ,r-plotrix)
+       ("r-dplyr" ,r-dplyr)
+       ("r-magrittr" ,r-magrittr)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-rtracklayer" ,r-rtracklayer)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-txdb-hsapiens-ucsc-hg19-knowngene"
+        ,r-txdb-hsapiens-ucsc-hg19-knowngene)))
+    (home-page "https://www.bioconductor.org/packages/ChIPseeker/")
+    (synopsis
+     "ChIPseeker for ChIP peak Annotation, Comparison, and Visualization")
+    (description "This package implements functions to retrieve the nearest
+genes around the peak, annotate genomic region of the peak, statstical methods
+for estimate the significance of overlap among ChIP peak data sets, and
+incorporate GEO database for user to compare the own dataset with those
+deposited in database.  The comparison can be used to infer cooperative
+regulation and thus can be used to generate hypotheses.  Several visualization
+functions are implemented to summarize the coverage of the peak experiment,
+average profile and heatmap of peaks binding to TSS regions, genomic
+annotation, distance to TSS, and overlap of peaks or genes.")
+    (license license:artistic2.0)))
+
 (define-public r-genelendatabase
   (package
     (name "r-genelendatabase")