summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 15:27:18 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:09 +0000
commitd979c916e84fcf6f75d5645e318aa1cd7024be5e (patch)
tree5255e1d41f6cd5be1b4622081685e0bcd3cd3816
parentd169b5a84d53f23f2cf9805481a16b5456ff0e2b (diff)
downloadguix-d979c916e84fcf6f75d5645e318aa1cd7024be5e.tar.gz
gnu: wayland: Find wayland-scanner when cross-compiling.
* gnu/packages/freedesktop.scm (wayland)[native-inputs]: Add
  pkg-config-for-build and 'this-package' when cross-compiling.
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9df7feffe1..ba0281b694 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1010,7 +1010,11 @@ Python.")
        ("doxygen" ,doxygen)
        ("pkg-config" ,pkg-config)
        ("xmlto" ,xmlto)
-       ("xsltproc" ,libxslt)))
+       ("xsltproc" ,libxslt)
+       ,@(if (%current-target-system)
+             `(("pkg-config-for-build" ,pkg-config-for-build)
+               ("wayland" ,this-package)) ; for wayland-scanner
+             '())))
     (inputs
      `(("expat" ,expat)
        ("libxml2" ,libxml2)))           ; for XML_CATALOG_FILES