summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-12-04 02:07:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:43 +0100
commite520c68fa9a9fcc5cf018cec15b05ee9ece5eb0a (patch)
treea21998a86ac343cff588aeb340f630a3c0ad82c2
parent2ed937e0aa02a788a569468cf83dd3762231bed3 (diff)
downloadguix-e520c68fa9a9fcc5cf018cec15b05ee9ece5eb0a.tar.gz
gnu: Add r-msmseda.
* gnu/packages/bioconductor.scm (r-msmseq): New variable.
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 867dc7083f..cfb59fc884 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8990,3 +8990,29 @@ as well as local access.  Developers can register a file extension, e.g.,
 `export()` methods based on classes representing file types, e.g.,
 `LoomFile()`.")
     (license license:artistic2.0)))
+
+(define-public r-msmseda
+  (package
+    (name "r-msmseda")
+    (version "1.28.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "msmsEDA" version))
+       (sha256
+        (base32
+         "1llmy8msxmrqik3s3439wffma1662vwvvcaz8q0a4g5ridkmdbrx"))))
+    (properties `((upstream-name . "msmsEDA")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-gplots" ,r-gplots)
+       ("r-mass" ,r-mass)
+       ("r-msnbase" ,r-msnbase)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)))
+    (home-page
+     "https://bioconductor.org/packages/msmsEDA")
+    (synopsis "Exploratory data analysis of LC-MS/MS data by spectral counts")
+    (description
+     "Exploratory data analysis to assess the quality of a set of LC-MS/MS
+experiments, and visualize de influence of the involved factors.")
+    (license license:gpl2)))