summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-01 00:09:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-01 00:09:07 -0400
commitf4699abc26ac0dee46328d5a129fb8fb288418c3 (patch)
tree0fdaf8f0c0321af90601082ffe4306c1544e09b2
parent4d31fe6b6c5c3758ae93f3d1c599072f5df977c4 (diff)
downloadguix-f4699abc26ac0dee46328d5a129fb8fb288418c3.tar.gz
gnu: Add ruby-pry-stack-explorer.
* gnu/packages/ruby.scm (ruby-pry-stack-explorer): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8fb4115aea..668b6924c5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6297,6 +6297,28 @@ frames in the call stack and can evaluate code in that context.")
     (home-page "https://github.com/banister/binding_of_caller")
     (license license:expat)))
 
+(define-public ruby-pry-stack-explorer
+  (package
+    (name "ruby-pry-stack-explorer")
+    (version "0.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "pry-stack_explorer" version))
+       (sha256
+        (base32
+         "157rd2n9pfvcmmicm0xkq8z4p6famaj13syrpra6b4032qpb1wn0"))))
+    (build-system ruby-build-system)
+    (arguments '(#:tests? #f))          ;no test suite in gem release
+    (propagated-inputs
+     `(("ruby-binding-of-caller" ,ruby-binding-of-caller)
+       ("ruby-pry" ,ruby-pry)))
+    (synopsis "Call-stack navigation plugin for the Pry REPL")
+    (description "@code{pry-stack_explorer} is a plugin for the Pry REPL that
+add support to navigate the call-stack.")
+    (home-page "https://github.com/pry/pry-stack_explorer")
+    (license license:expat)))
+
 (define-public ruby-gherkin
   (package
     (name "ruby-gherkin")