summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-18 16:37:29 +0100
committerMarius Bakke <marius@gnu.org>2022-01-18 19:35:54 +0100
commit146e931523853ecabdc66834f14193755251df4c (patch)
tree195d633da25a4180155a376698de707b6d01dc12
parentf5e78d45468f707f9d7597451c56b1adc92cd174 (diff)
downloadguix-146e931523853ecabdc66834f14193755251df4c.tar.gz
gnu: python-lazr-delegates: Fix test failure.
* gnu/packages/python-xyz.scm (python-lazr-delegates)[arguments]: Invoke
'nosetests' directly instead of through setup.py.  While at it, respect
'--without-tests'.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b94045d210..52ee3b2f81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26082,8 +26082,8 @@ and plain text.")
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "python" "setup.py" "nosetests"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests? (invoke "nosetests")))))))
     (native-inputs
      (list python-nose))
     (propagated-inputs