summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-26 09:00:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-26 09:00:45 +0300
commit1aad42e24cc927cea34dd8e4ef49f8afdbd102e8 (patch)
tree1d90c6254a96cc278da173fb69cee76731a2cddc
parentffcc5395b790035e22cbb155b4e30bd4152915e1 (diff)
downloadguix-1aad42e24cc927cea34dd8e4ef49f8afdbd102e8.tar.gz
gnu: python-joblib: Honor #:tests? flag.
* gnu/packages/python-xyz.scm (python-joblib)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f1b552d007..cc724ed153 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4008,7 +4008,9 @@ logic-free templating system Mustache.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _ (invoke "pytest" "-v" "joblib"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-v" "joblib")))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (home-page "https://joblib.readthedocs.io/")