summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:26:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:32 +0100
commit1b1a1067d03d383398ccee6c39c8994d03abc99c (patch)
tree619fa965e37e2d9545c30c28c2d80c0425b0015b
parenta5044b6a0ecc046ae29575bcc5a3e1ba7c5567f1 (diff)
downloadguix-1b1a1067d03d383398ccee6c39c8994d03abc99c.tar.gz
gnu: ghc-attoparsec: Update to 0.13.2.2.
* gnu/packages/haskell.scm (ghc-attoparsec): Update to 0.13.2.2.
[arguments]: Disable tests.
[native-inputs]: Remove ghc-test-framework and ghc-test-framework-quickcheck2;
add ghc-tasty and ghc-tasty-quickcheck.
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e460a438f4..192a227600 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2272,7 +2272,7 @@ with slicing and Clang-style colored diagnostics.")
 (define-public ghc-attoparsec
   (package
     (name "ghc-attoparsec")
-    (version "0.13.0.1")
+    (version "0.13.2.2")
     (source
      (origin
        (method url-fetch)
@@ -2282,16 +2282,20 @@ with slicing and Clang-style colored diagnostics.")
              ".tar.gz"))
        (sha256
         (base32
-         "0cprkr7bl4lrr80pz8mryb4rbfwdgpsrl7g0fbcaybhl8p5hm26f"))))
+         "0j6qcwd146yzlkc9mcvzvnixsyl65n2a68l28322q5v9p4g4g4yx"))))
     (build-system haskell-build-system)
+    ;; FIXME: at least on test fails with QuickCheck > 2.9.2.  Once upstream
+    ;; has updated the tests to work with a later version of QuickCheck we can
+    ;; re-enable them.
+    (arguments `(#:tests? #f))
     (inputs
      `(("ghc-scientific" ,ghc-scientific)
        ("ghc-text" ,ghc-text)))
     (native-inputs
-     `(("ghc-quickcheck" ,ghc-quickcheck)
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+       ("ghc-quickcheck" ,ghc-quickcheck)
        ("ghc-quickcheck-unicode" ,ghc-quickcheck-unicode)
-       ("ghc-test-framework" ,ghc-test-framework)
-       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
        ("ghc-vector" ,ghc-vector)))
     (home-page "https://github.com/bos/attoparsec")
     (synopsis "Fast combinator parsing for bytestrings and text")