summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-07-19 11:33:52 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-07-19 11:33:52 +0200
commit1c5901ae4e962b1726de909f3e402804a1e5984a (patch)
tree006f46d0a666369086d9e40584196bab3d487c18
parentfd7b950858be1f57da2bbab89b105721095e73b8 (diff)
downloadguix-1c5901ae4e962b1726de909f3e402804a1e5984a.tar.gz
gnu: sbcl-mcclim-fonts-truetype: Fix build.
* gnu/packages/lisp-xyz.scm (sbcl-mcclim-fonts-truetype)[inputs]: Add
  font-dejavu.
  [arguments]: Add 'fix-paths' phase and don't disable test phase.
-rw-r--r--gnu/packages/lisp-xyz.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4eefa94258..985ab05af7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -54,6 +54,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages enchant)
+  #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
@@ -12875,13 +12876,22 @@ specification}, a toolkit for writing GUIs in Common Lisp.")
        ("cl-paths-ttf" ,sbcl-cl-paths-ttf)
        ("cl-vectors" ,sbcl-cl-vectors)
        ("clim-basic" ,sbcl-clim-basic)
+       ("font-dejavu" ,font-dejavu)
        ("zpb-ttf" ,sbcl-zpb-ttf)))
     (arguments
-     '(#:asd-file "./Extensions/fonts/mcclim-fonts.asd"
+     '(#:asd-file "Extensions/fonts/mcclim-fonts.asd"
        #:asd-system-name "mcclim-fonts/truetype"
-       ;; Tests want access to user's fonts, which are not available in
-       ;; build container.
-       #:tests? #f))))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; mcclim-truetype uses DejaVu as default font and
+             ;; sets the path at build time.
+             (substitute* "Extensions/fonts/fontconfig.lisp"
+               (("/usr/share/fonts/truetype/dejavu/")
+                (string-append (assoc-ref inputs "font-dejavu")
+                               "/share/fonts/truetype/")))
+             #t)))))))
 
 (define-public sbcl-mcclim-fonts-clx-truetype
   (package