summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:43:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:46 -0400
commit2841af8b9650f427b21e026aeca2def79aaa99ac (patch)
treee65f737684a321617af88bba75a1c153d268ec33
parent0202863b7692c9f2048829d093e7e15d808f6d92 (diff)
downloadguix-2841af8b9650f427b21e026aeca2def79aaa99ac.tar.gz
gnu: Remove python2-invoke.
* gnu/packages/python-xyz.scm (python2-invoke): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 599354e18b..9b55cf3e7c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19865,19 +19865,6 @@ JSON) codec.")
      instead of servers and network commands.")
     (license license:bsd-3)))
 
-(define-public python2-invoke
-  (let ((parent (package-with-python2 python-invoke)))
-    (package
-      (inherit parent)
-      (arguments
-       (substitute-keyword-arguments (package-arguments parent)
-         ((#:phases phases #t)
-          `(modify-phases ,phases
-             (delete 'delete-python2-code)
-             (add-after 'unpack 'delete-python3-code
-               (lambda _
-                 (delete-file-recursively "invoke/vendor/yaml3"))))))))))
-
 (define-public python-automat
   (package
     (name "python-automat")