summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-05 15:53:38 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:13 -0400
commit34e5ba942ec28096298b471a011144155e2720da (patch)
tree097a0789707e61010fea5a2be7fea7e07c8ee6d8
parent8a17609dd02ff1d54bb32a158cead6bcba06a145 (diff)
downloadguix-34e5ba942ec28096298b471a011144155e2720da.tar.gz
gnu: go-1.17: Fix test suite on powerpc64le-linux.
* gnu/packages/golang.scm (go-1.17)[arguments]: Use custom
'patch-gcc:lib phase on powerpc64le-linux. Add a phase to adjust the
allowed size of an executable in the test suite.
[inputs]: Keep gcc:lib as an input on powerpc64le-linux.
(go-1.18)[arguments]: Delete custom 'adjust-test-suite phase.
-rw-r--r--gnu/packages/golang.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2b75730dcd..9c8decda61 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -700,7 +700,6 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                (substitute* "src/time/zoneinfo_unix.go"
                  (("/usr/share/zoneinfo/") tzdata-path)))))
          ;; Keep this synchronized with the package inputs.
-         ;; Also keep syncthonized with later versions of go.
          ,@(if (or (target-arm?) (target-ppc64le?))
              '((add-after 'unpack 'patch-gcc:lib
                  (lambda* (#:key inputs #:allow-other-keys)
@@ -864,6 +863,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
      (substitute-keyword-arguments (package-arguments go-1.17)
        ((#:phases phases)
         `(modify-phases ,phases
+           (delete 'adjust-test-suite)
            ;; See the platforms using this phase in go-1.17.
            (replace 'patch-gcc:lib
              (lambda* (#:key inputs #:allow-other-keys)