summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-13 16:24:30 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-13 16:26:53 +0200
commit3abd66aa0cb8820124d249e497c95bd0cadb8ca2 (patch)
treeb20615264bf1acfadbcc87fd4d9fbce1999b47d4
parentc86447f486506d468e08ef42f5683883cafadfda (diff)
downloadguix-3abd66aa0cb8820124d249e497c95bd0cadb8ca2.tar.gz
gnu: make-bootstrap: Remove duplicate definition of 'bash-static'.
* gnu/packages/make-bootstrap.scm (%bash-static): Remove.
(%static-inputs): Use STATIC-BASH instead of %BASH-STATIC.
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index def9c23b17..2c14e748f2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -114,9 +114,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                                 (current-source-location)
                                 #:native-inputs native-inputs))
 
-(define %bash-static
-  (static-package bash-minimal))
-
 (define %static-inputs
   ;; Packages that are to be used as %BOOTSTRAP-INPUTS.
   (let ((coreutils (package (inherit coreutils)
@@ -184,7 +181,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                               (("-Wl,-export-dynamic") "")))
                           ,phases)))))
                 (inputs (if (%current-target-system)
-                            `(("bash" ,%bash-static))
+                            `(("bash" ,static-bash))
                             '()))))
         (finalize (compose static-package
                            package-with-relocatable-glibc)))
@@ -200,7 +197,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                ("sed" ,sed)
                ("grep" ,grep)
                ("gawk" ,gawk)))
-      ("bash" ,%bash-static))))
+      ("bash" ,static-bash))))
 
 (define %static-binaries
   (package