summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-13 00:19:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-13 00:19:24 +0100
commit4889be6ceb794d8c535d90df007e012ab7c2161e (patch)
tree3b0404a32feafedc35f10a3fcc20c1715d849764
parentaaadd6e2e1bb4f814dfc7b30d8d23b91526c4deb (diff)
downloadguix-4889be6ceb794d8c535d90df007e012ab7c2161e.tar.gz
gnu: blender: Fix build with Python 3.8.
* gnu/packages/graphics.scm (blender)[arguments]: Remove 'm' suffix from
python directories.
-rw-r--r--gnu/packages/graphics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7e3685482d..fcd5b0c6e2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -114,11 +114,11 @@
                "-DWITH_MOD_OCEANSIM=ON"
                "-DWITH_OPENSUBDIV=ON"
                "-DWITH_PYTHON_INSTALL=OFF"
-               (string-append "-DPYTHON_LIBRARY=python" ,python-version "m")
+               (string-append "-DPYTHON_LIBRARY=python" ,python-version)
                (string-append "-DPYTHON_LIBPATH=" (assoc-ref %build-inputs "python")
                               "/lib")
                (string-append "-DPYTHON_INCLUDE_DIR=" (assoc-ref %build-inputs "python")
-                              "/include/python" ,python-version "m")
+                              "/include/python" ,python-version)
                (string-append "-DPYTHON_VERSION=" ,python-version)
                (string-append "-DPYTHON_NUMPY_PATH="
                               (assoc-ref %build-inputs "python-numpy")