summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-15 03:16:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-15 03:26:21 +0200
commit492ad09f413e477ec7eea22a52424472498c4f9e (patch)
treec56a901eb234f82ba8fdd56edb446c69bc8baf31
parent2b4dc589e9ee3d9f65ecc0a4a598283771d4f456 (diff)
downloadguix-492ad09f413e477ec7eea22a52424472498c4f9e.tar.gz
gnu: gfbgraph: Remove obsolete configure flag.
* gnu/packages/gnome.scm (gfbgraph)[arguments]: Build gtk-doc documentation.
[native-inputs]: Add gtk-doc.
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dce9639cb8..6c7406d3f1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8655,14 +8655,14 @@ compiled.")
                 "1dp0v8ia35fxs9yhnqpxj3ir5lh018jlbiwifjfn8ayy7h47j4fs"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     `(#:tests? #f ; Tests appear to require the network.
-       ;; FIXME --enable-gtk-doc fails even with gtk-doc as a native-input.
-       #:configure-flags '("--disable-gtk-doc"
-                           "--disable-static"
+     `(#:tests? #f                      ; tests appear to require the network
+       #:configure-flags '("--disable-static"
+                           "--enable-gtk-doc"
                            "--enable-introspection")))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("gobject-introspection" ,gobject-introspection)))
+     `(("gobject-introspection" ,gobject-introspection)
+       ("gtk-doc" ,gtk-doc)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("json-glib" ,json-glib)
        ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")