summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:30:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:12 +0200
commit53338fa64f3d7d9d91ead64c79930bec34c3bb7c (patch)
tree5d9962e756327d9228fdf95f120ad9ba4e8163b5
parent3a3a68eb4d5da031ff0a20ae32512c1c93d685be (diff)
downloadguix-53338fa64f3d7d9d91ead64c79930bec34c3bb7c.tar.gz
gnu: emacs-engine-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-engine-mode)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5de7b85d58..8180a6d719 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7796,13 +7796,13 @@ the nick color and the background color
     (version "2.0.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/hrs/engine-mode/archive/"
-                           "v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hrs/engine-mode.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1vm4p7pcp1vnwwxvps1bhm7i7hkabqqxl898knxf2hqvxys76684"))))
+        (base32 "02xas46nl28mascqsyr1zcd4hn15bh0fjv2xlxv1kmrj0pis94ml"))))
     (build-system emacs-build-system)
     (synopsis "Minor mode for defining and querying search engines")
     (description "@code{engine-mode} is a global minor mode for Emacs.  It