summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-02 21:46:44 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-02 21:46:44 +0200
commit535dc6cf95c71ae1fdccc8e3bacbc282a11d5d78 (patch)
tree1c928e3353bd118e4d5f4a7f686bc27e98ac95f4
parent22e32e6938431c814e35dd830a65e7035d9dc471 (diff)
downloadguix-535dc6cf95c71ae1fdccc8e3bacbc282a11d5d78.tar.gz
gnu: Add perl-xml-simple.
* gnu/packages/xml.scm (perl-xml-simple): New variable.
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 28c99b1f8c..fb50c25c09 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -140,6 +140,29 @@ as extra arguments to the parse methods, in which case they override options
 given at XML::Parser creation time.")
     (home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
 
+(define-public perl-xml-simple
+  (package
+    (name "perl-xml-simple")
+    (version "2.20")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "mirror://cpan/authors/id/G/GR/GRANTM/XML-Simple-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "0jj3jiray1l4pi9wkjcpxjc3v431whdwx5aqnhgdm4i7h3817zsw"))))
+    (build-system perl-build-system)
+    (inputs
+     `(("perl-xml-parser" ,perl-xml-parser)))
+    (license (package-license perl))
+    (synopsis "Perl module for easy reading/writing of XML files")
+    (description
+     "The XML::Simple module provides a simple API layer on top of an
+underlying XML parsing module (either XML::Parser or one of the SAX2
+parser modules).")
+    (home-page "http://search.cpan.org/~grantm/XML-Simple-2.20/lib/XML/Simple.pm")))
+
 (define-public xmlto
   (package
     (name "xmlto")