summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-28 15:40:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 15:41:03 +0200
commit5f8642ea6ae675d0fb5b06e616064458433087d3 (patch)
tree6a089894d77f07256568514a590605bf6f8ca0ef
parentfbd2b8da5d7e6edb16ba7128324f6bc48ac68569 (diff)
downloadguix-5f8642ea6ae675d0fb5b06e616064458433087d3.tar.gz
gnu: libxml2: Move static library to separate output.
* gnu/packages/xml.scm (libxml2)[outputs, arguments]: New fields.
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 1bf99f2fe5..85fd553b40 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -129,6 +129,20 @@ hierarchical form with variable field lengths.")
               (base32
                "0ci7is75bwqqw2p32vxvrk6ds51ik7qgx73m920rakv5jlayax0b"))))
     (build-system gnu-build-system)
+    (outputs '("out" "static"))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'install 'move-static-libs
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((src (string-append (assoc-ref outputs "out") "/lib"))
+                            (dst (string-append (assoc-ref outputs "static")
+                                                "/lib")))
+                        (mkdir-p dst)
+                        (for-each (lambda (ar)
+                                    (rename-file ar (string-append dst "/"
+                                                                   (basename ar))))
+                                  (find-files src "\\.a$"))
+                        #t))))))
     (home-page "http://www.xmlsoft.org/")
     (synopsis "C parser for XML")
     (propagated-inputs `(("zlib" ,zlib))) ; libxml2.la says '-lz'.