summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-11-04 18:33:32 +0100
committerFederico Beffa <beffa@fbengineering.ch>2014-11-04 18:33:32 +0100
commit6f885c059c9b9426871fc2e97eeef712832039cb (patch)
tree9354d3f6fa16225c5f336e2494874f0a4a7b7605
parentcd14b5e3f3a186512c80da5e750c8726add706cc (diff)
downloadguix-6f885c059c9b9426871fc2e97eeef712832039cb.tar.gz
gnu: Add gnome-themes-standard.
* gnu/packages/gnome.scm (gnome-themes-standard): New variable.
-rw-r--r--gnu/packages/gnome.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6b458c6400..f514b31fcf 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1201,3 +1201,47 @@ engineering.")
     (license
     ;; Dual licensed under GPLv2 or GPLv3 (both without "or later")
      (list license:gpl2 license:gpl3))))
+
+(define-public gnome-themes-standard
+  (package
+    (name "gnome-themes-standard")
+    ;; The version of this package should be the same as the version of
+    ;; gnome-desktop.
+    (version (package-version gnome-desktop))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnome/sources/" name "/" 
+                           (version-major+minor version) "/" name "-"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "0f2b3ypkfvrdsxcvp14ja9wqj382f1p46yrjvhhxkkjgagy6qb41"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("gtk+-2" ,gtk+-2)
+       ("librsvg" ,librsvg)
+       ("libxml2" ,libxml2)
+       ("glib" ,glib)))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:phases
+       (alist-cons-before
+        'build 'use-full-cache
+        ;; Use librsvg's loaders.cache instead of the one provided by
+        ;; gdk-pixbuf because the latter does not include support for SVG
+        ;; files.
+        (lambda* (#:key inputs #:allow-other-keys)
+          (setenv "GDK_PIXBUF_MODULE_FILE" 
+                  (car (find-files (assoc-ref inputs "librsvg") 
+                                   "loaders\\.cache"))))
+        %standard-phases)))
+    (home-page "https://launchpad.net/gnome-themes-standard")
+    (synopsis "Default GNOME 3 themes")
+    (description
+     "The default GNOME 3 themes (Adwaita and some accessibility themes).")
+    (license license:lgpl2.1+)))