summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-05-08 12:23:37 +0300
committerAlex Kost <alezost@gmail.com>2016-05-16 18:01:18 +0300
commit789bda83d2f356a55a2c65ff1b4ffe3431fc11b3 (patch)
treefa335f8104cfc496993df7d45748bcab6e6d2c30
parent99404fff9f8be0478191dfd5a4ebbb5822527172 (diff)
downloadguix-789bda83d2f356a55a2c65ff1b4ffe3431fc11b3.tar.gz
gnu: mu: Install emacs files in a proper place.
* gnu/packages/mail.scm (mu)[arguments]: Add 'patch-configure.ac' phase
  to avoid adding "mu4e" sub-directory to 'lispdir' variable.
-rw-r--r--gnu/packages/mail.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a2af7c7f97..526e63829d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -367,7 +367,16 @@ repository and Maildir/IMAP as LOCAL repository.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'autoreconf
+         (add-after 'unpack 'patch-configure.ac
+           ;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
+           ;; so our Emacs package can't find it.  Setting "--with-lispdir"
+           ;; configure flag doesn't help because "mu4e" will be added to
+           ;; the lispdir anyway, so we have to modify "configure.ac".
+           (lambda _
+             (substitute* "configure.ac"
+               (("^ +lispdir=.*") ""))
+             #t))
+         (add-after 'patch-configure.ac 'autoreconf
            (lambda _
              (zero? (system* "autoreconf" "-vi"))))
          (add-before 'check 'check-tz-setup