summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-17 11:00:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-17 11:11:15 +0200
commit7b3c9cbb52b00b66c1299c76ecc507514da84ac9 (patch)
tree9dfd6fb61e469d556cf7b2ddca2c12eecee5b15c
parent93825a326c79d5ed8d0dbd41bf8aeffa80ffa7c9 (diff)
downloadguix-7b3c9cbb52b00b66c1299c76ecc507514da84ac9.tar.gz
gnu: python-pytorch-for-r-torch: Update to 1.13.1.
* gnu/packages/machine-learning.scm (python-pytorch-for-r-torch): Update to
1.13.1.
[source]: Adjust RUNPATH in snippet.
-rw-r--r--gnu/packages/machine-learning.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 752c6929bd..90a3e153ce 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3364,7 +3364,7 @@ Note: currently this package does not provide GPU support.")
   (package
     (inherit python-pytorch)
     (name "python-pytorch")
-    (version "1.12.1")
+    (version "1.13.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3374,7 +3374,7 @@ Note: currently this package does not provide GPU support.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1wimgnmn8kfazc8vhf65b9psdwj80n3chzkd8ic28541ac2zqzpk"))
+                "17yxjzwp4zp75fz7czgz9acijzw7dpyqcza50v8y1x7hfg2gw369"))
               (patches (search-patches "python-pytorch-system-libraries.patch"
                                        "python-pytorch-runpath.patch"))
               (modules '((guix build utils)))
@@ -3394,7 +3394,10 @@ Note: currently this package does not provide GPU support.")
                               "gloo" "googletest" "ios-cmake" "NNPACK"
                               "onnx" "protobuf" "pthreadpool"
                               "pybind11" "python-enum" "python-peachpy"
-                              "python-six" "tbb" "XNNPACK" "zstd"))))))))
+                              "python-six" "tbb" "XNNPACK" "zstd"))
+                  (substitute* "functorch/CMakeLists.txt"
+                    (("\\$\\{_rpath_portable_origin\\}/../torch/lib")
+                     "$ORIGIN/../torch/lib"))))))))
 
 ;; Keep this in sync with python-pytorch
 (define-public python-torchvision