summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 16:38:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 17:31:19 +0100
commit82e7a51ccdd901ef5b28a5f0f3b12f5ead0688f1 (patch)
tree8af519cd652a8124a8b05b386cd3781fc898c313
parent30559d8ffd901e3341987d1566a2772553f792ec (diff)
downloadguix-82e7a51ccdd901ef5b28a5f0f3b12f5ead0688f1.tar.gz
gnu: efibootmgr: Remove obsolete configure flag.
* gnu/packages/linux.scm (efibootmgr)[arguments]: Don't override CFLAGS.
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 12cdc960ad..1976e24cba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4129,7 +4129,7 @@ interface to the variable facility of UEFI boot firmware.")
                 "0pzn67vxxaf7jna4cd0i4kqm60h04kb21hckksv9z82q9gxra1wm"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; No tests.
+     `(#:tests? #f ;no tests
        #:make-flags (list (string-append "prefix=" %output)
                           (string-append "libdir=" %output "/lib")
                           ;; EFIDIR denotes a subdirectory relative to the
@@ -4137,11 +4137,7 @@ interface to the variable facility of UEFI boot firmware.")
                           ;; installed (known as OS_VENDOR in the code).
                           ;; GRUB overrides this, as such it's only used if
                           ;; nothing else is specified on the command line.
-                          "EFIDIR=gnu"
-                          ;; Override CFLAGS to add efivar include directory.
-                          (string-append "CFLAGS=-O2 -g -flto -I"
-                                         (assoc-ref %build-inputs "efivar")
-                                         "/include/efivar"))
+                          "EFIDIR=gnu")
        #:phases (modify-phases %standard-phases (delete 'configure))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))