summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-12-30 22:43:09 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-12-30 22:43:20 +0100
commit846e2e6188218646200ab08101b7d7e28fa89f84 (patch)
treeb25bed1196a39c8ae1c7f3f6c0b32677f49a21a5
parent32feb2c5f6c33421836cc525aed730be83799939 (diff)
downloadguix-846e2e6188218646200ab08101b7d7e28fa89f84.tar.gz
gnu: Add emacs-sly-stepper.
* gnu/packages/emacs-xyz.scm (emacs-sly-stepper): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 02a487c9aa..0fb174f001 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9687,6 +9687,45 @@ file.")
 inside the source file.")
       (license license:gpl3+))))
 
+(define-public emacs-sly-stepper
+  (let ((commit "cd7fd00f9a701246e2a9ba8c37166dcae2fde04e"))
+    (package
+      (name "emacs-sly-stepper")
+      (version (git-version "0.0.0" "1" commit))
+      (home-page "https://github.com/joaotavora/sly-stepper")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "09ll9dv8fd5dgnki82hcd48nm4qdzzn8wpva0zzr69zkjwzf9v25"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-sly" ,emacs-sly)))
+      (arguments
+       '(#:include (cons* "\\.lisp$" "\\.asd$" %default-include)
+         #:phases
+         (modify-phases %standard-phases
+           ;; The package provides autoloads.
+           (delete 'make-autoloads)
+           (delete 'enable-autoloads-compilation)
+           (add-after 'add-source-to-load-path 'add-contrib-to-emacs-load-path
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((sly (assoc-ref inputs "emacs-sly")))
+                 (setenv "EMACSLOADPATH"
+                         (string-append sly "/share/emacs/site-lisp/contrib:"
+                                        (getenv "EMACSLOADPATH"))))
+               #t)))))
+      (synopsis "Portable Common Lisp stepper interface for Emacs")
+      (description
+       "This package features a new, portable, visual stepping facility for
+Common Lisp, realized as an extension to SLY.")
+      (license license:gpl3+))))
+
 (define-public emacs-sly-package-inferred
   (let ((commit "800e71e2be631422277e2ec77e6d6f6ea20e95ef")
         (revision "1"))