summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 08:44:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:18 +0200
commit89f1a4a415fb00723522e786edf519deb6dd40e7 (patch)
tree41418ec300612286ad5825751f45e0ab48d50199
parenta0a8fdeaf2db2695dd7944ee7d2e5eeade9e600b (diff)
downloadguix-89f1a4a415fb00723522e786edf519deb6dd40e7.tar.gz
gnu: Remove python2-jupyter-console.
* gnu/packages/python-xyz.scm (python2-jupyter-console): Remove variable.
(python-jupyter-console)[properties]: Remove python2-variant.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c3966c8016..828a3561fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10612,36 +10612,6 @@ in the data.")
     (description "This package provides a terminal-based console frontend for
 Jupyter kernels.  It also allows for console-based interaction with non-Python
 Jupyter kernels such as IJulia and IRKernel.")
-    (properties `((python2-variant . ,(delay python2-jupyter-console))))
-    (license license:bsd-3)))
-
-(define-public python2-jupyter-console
-  (package
-    (name "python2-jupyter-console")
-    (version "5.2.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "jupyter_console" version))
-       (sha256
-        (base32
-         "1kam1qzgwr7srhm5r6aj90di5sws4bq0jmiw15452ddamb9yspal"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2
-       #:tests? #f))    ; Tests only run in a TTY.
-    (propagated-inputs
-     `(("python2-ipykernel" ,python2-ipykernel)
-       ("python2-jupyter-client" ,python2-jupyter-client)
-       ("python2-prompt-toolkit" ,python2-prompt-toolkit-1)
-       ("python2-pygments" ,python2-pygments)))
-    (native-inputs
-     `(("python2-nose" ,python2-nose)))
-    (home-page "https://jupyter.org")
-    (synopsis "Jupyter terminal console")
-    (description "This package provides a terminal-based console frontend for
-Jupyter kernels.  It also allows for console-based interaction with non-Python
-Jupyter kernels such as IJulia and IRKernel.")
     (license license:bsd-3)))
 
 ;; The python-ipython and python-jupyter-console require each other. To get