summary refs log tree commit diff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-04-10 00:48:07 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-16 15:43:44 +0200
commit8b2d0654effbf3b0222e7b68c90aa3d714ca02c5 (patch)
tree92f9f9fc3543abad1eaf1b8d1d4f194aebf83775
parent18657219ab2ac3fc904ab5e1a2231af234ccdb78 (diff)
downloadguix-8b2d0654effbf3b0222e7b68c90aa3d714ca02c5.tar.gz
gnu: Add emacs-totp.
* gnu/packages/emacs-xyz.scm (emacs-totp): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d209f3c43c..f1a0df877c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36735,6 +36735,30 @@ categories and highlighting specific modes that many commands use to
 accomplish different tasks.")
       (license license:asl2.0))))
 
+(define-public emacs-totp
+  (let ((commit "a5e059b8475b32bc7f5ddadda248cf84449ed722") ;no releases
+        (revision "0"))
+    (package
+      (name "emacs-totp")
+      (home-page "https://github.com/juergenhoetzel/emacs-totp")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0b76fxk9r3n9zii75q1957ivb6ap5px5h87kagxz083nl77jky7a"))))
+      (build-system emacs-build-system)
+      (synopsis "Generate Time-based One-time Passwords (TOTP) in Emacs")
+      (description
+       "emacs-TOTP implements @acronym{TOTP, Time-based One-time Passwords} as
+specified in RFC 6238.  It supports reading secrets in HEX and multiple base32
+variations, including non-standard base32 encodings.")
+       (license license:gpl3+))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar