summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-18 23:17:56 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-18 23:17:56 +0200
commit8e67a84a99b277e789bbe6478ea1c9225a703e35 (patch)
treefa246ec0ec486d26fb7e1483c8f0982717376b2a
parentcbdd76c493e1f76ad9cb3b2e0fcc73b9591b768a (diff)
downloadguix-8e67a84a99b277e789bbe6478ea1c9225a703e35.tar.gz
gnu: python-ipython: Update to 7.27.0.
* gnu/packages/python-xyz.scm (python-ipython): Update to 7.27.0.
  [inputs]: Add matplotlib-inline.
  [arguments]: Update 'fix-tests' phase to disable "pylabtools" test.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1f45da0d0c..b319793b38 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8102,13 +8102,13 @@ callback signature using a prototype function.")
 (define-public python-ipython
   (package
     (name "python-ipython")
-    (version "7.9.0")
+    (version "7.27.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "ipython" version ".tar.gz"))
        (sha256
-        (base32 "103jkw18z7fnwdal1mdbijjxi1fndzn31g887lmj7ddpf2r07lyz"))))
+        (base32 "04xgymypnbfgf2q0d5b0hanjbjsp53f055sh1p8xlq52vyzmxdaq"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-backcall" ,python-backcall)
@@ -8116,6 +8116,7 @@ callback signature using a prototype function.")
        ("python-prompt-toolkit" ,python-prompt-toolkit-2)
        ("python-terminado" ,python-terminado)
        ("python-matplotlib" ,python-matplotlib)
+       ("python-matplotlib-inline" ,python-matplotlib-inline)
        ("python-numpy" ,python-numpy)
        ("python-numpydoc" ,python-numpydoc)
        ("python-jedi" ,python-jedi)
@@ -8174,6 +8175,9 @@ callback signature using a prototype function.")
              (delete-file "IPython/core/tests/test_display.py")
              ;; AttributeError: module 'IPython.core' has no attribute 'formatters'
              (delete-file "IPython/core/tests/test_interactiveshell.py")
+             ;; AttributeError: module 'matplotlib_inline' has no
+             ;; attribute 'backend_inline'
+             (delete-file "IPython/core/tests/test_pylabtools.py")
              #t)))))
     (home-page "https://ipython.org")
     (synopsis "IPython is a tool for interactive computing in Python")