summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:01:16 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:36 -0500
commit900e3c0e0e87e2da7e5297e39bbc8119b7209937 (patch)
tree6fcafc19e1f719fdfb2e2478fe6b2ac5b1d72d3d
parent81f2373cd4f3a6c4992573d9cacd0ff57b63ffd2 (diff)
downloadguix-900e3c0e0e87e2da7e5297e39bbc8119b7209937.tar.gz
gnu: Add python-zope-testing.
* gnu/packages/python.scm (python-zope-testing, python2-zope-testing):
  New variables.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0aabe083ea..3dd50ff389 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6086,3 +6086,29 @@ that have uses outside of the Zope framework.")
 
 (define-public python2-zope-exceptions
   (package-with-python2 python-zope-exceptions))
+
+(define-public python-zope-testing
+  (package
+    (name "python-zope-testing")
+    (version "4.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/z"
+                           "/zope.testing/zope.testing-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1yvglxhzvhl45mndvn9gskx2ph30zz1bz7rrlyfs62fv2pvih90s"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-zope-exceptions" ,python-zope-exceptions)))
+    (propagated-inputs
+     `(("python-zope-interface" ,python-zope-interface)))
+    (home-page "http://pypi.python.org/pypi/zope.testing")
+    (synopsis "Zope testing helpers")
+    (description "Zope.testing provides a number of testing utilities for HTML
+forms, HTTP servers, regular expressions, and more.")
+    (license zpl2.1)))
+
+(define-public python2-zope-testing
+  (package-with-python2 python-zope-testing))