summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-11 17:36:45 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:17 -0500
commit91e40dd2ed3fdf9cc750896358c02bea681a31c7 (patch)
tree0d222d6b01e5488e182a47081e009aa3ff3ed156
parent532292b5622a8a009ffc901153f3d69a13ea50b8 (diff)
downloadguix-91e40dd2ed3fdf9cc750896358c02bea681a31c7.tar.gz
gnu: librsvg-next: Do not propagate gdk-pixbuf.
Propagating gdk-pixbuf rather than gdk-pixbuf+svg is dangerous as it clashes
with GTK+'s own gdk-pixbuf+svg propagation.

* gnu/packages/gnome.scm (librsvg-next)[propagated-inputs]: Remove gdk-pixbuf.
[inputs]: Add gdk-pixbuf+svg.
-rw-r--r--gnu/packages/gnome.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b2bc1443b6..7785b3b9d9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3553,6 +3553,7 @@ for dealing with different structured file formats.")
      `(("bzip2" ,bzip2)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("harfbuzz" ,harfbuzz)
        ("libcroco" ,libcroco)
        ("libgsf" ,libgsf)
@@ -3560,7 +3561,6 @@ for dealing with different structured file formats.")
        ("pango" ,pango)))
     (propagated-inputs
      `(("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (synopsis "SVG rendering library")
     (description "Librsvg is a library to render SVG images to Cairo surfaces.