summary refs log tree commit diff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:29 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:15 -0700
commit97b26920a8be853e87f971737137bd671e492993 (patch)
tree6ac791b01a9e6855e9dbcf7a237f38393cc9ec5e
parente0195ea87576bd578d4847fc94d0d2605295e6dc (diff)
downloadguix-97b26920a8be853e87f971737137bd671e492993.tar.gz
gnu: Add ghc-abstract-par.
* gnu/packages/haskell.scm (ghc-abstract-par): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2efd785529..ffc6030099 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9234,4 +9234,27 @@ using Template Haskell")
 \(e.g. if you want to be able to call the testgroup from another module).")
     (license license:bsd-3)))
 
+(define-public ghc-abstract-par
+  (package
+    (name "ghc-abstract-par")
+    (version "0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "abstract-par-" version "/"
+                           "abstract-par-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0q6qsniw4wks2pw6wzncb1p1j3k6al5njnvm2v5n494hplwqg2i4"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/simonmar/monad-par")
+    (synopsis "Abstract parallelization interface for Haskell")
+    (description "This Haskell package is an abstract interface
+only.  It provides a number of type clasess, but not an
+implementation.  The type classes separate different levels
+of @code{Par} functionality.  See the @code{Control.Monad.Par.Class}
+module for more details.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here