summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 17:19:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 17:19:58 +0100
commita97796cd5333e7ec0cb07bc480b435c22f8d58fc (patch)
tree1022098ca6514d74f90079f248eb6a3ec372f143
parent4291f36a22081e25fad1346178d14f3a3c9df1c2 (diff)
downloadguix-a97796cd5333e7ec0cb07bc480b435c22f8d58fc.tar.gz
gnu: Add r-valr.
* gnu/packages/cran.scm (r-valr): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4baf0307ba..b04a69d5c1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11688,3 +11688,32 @@ propagation and an algorithm for exemplar-based agglomerative clustering that
 can also be used to join clusters obtained from affinity propagation.  Various
 plotting functions are available for analyzing clustering results.")
     (license license:gpl2+)))
+
+(define-public r-valr
+  (package
+    (name "r-valr")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "valr" version))
+       (sha256
+        (base32
+         "14jhrwkiwmha3vlmm7b50n2xxyizj6ddmy89gb20mpzq7qhz1ika"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-broom" ,r-broom)
+       ("r-dplyr" ,r-dplyr)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-rcpp" ,r-rcpp)
+       ("r-readr" ,r-readr)
+       ("r-rlang" ,r-rlang)
+       ("r-stringr" ,r-stringr)
+       ("r-tibble" ,r-tibble)))
+    (home-page "http://github.com/rnabioco/valr")
+    (synopsis "Genome interval arithmetic in R")
+    (description
+     "This package enables you to read and manipulate genome intervals and
+signals.  It provides functionality similar to command-line tool suites within
+R, enabling interactive analysis and visualization of genome-scale data.")
+    (license license:expat)))