summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-25 11:58:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-25 14:01:32 +0300
commitab961fe54232baf093c91cb7bc8433eebbadf461 (patch)
tree23ecd293ef307de1a224fe8e41c7fa73dac24e50
parent2de88bcd7a67305e23929fd73deca1b5df22aa9e (diff)
downloadguix-ab961fe54232baf093c91cb7bc8433eebbadf461.tar.gz
gnu: python-cython: Honor #:tests? flag.
* gnu/packages/python-xyz.scm (python-cython)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9aa2dc8d32..f1b552d007 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5185,16 +5185,17 @@ provides additional functionality on the produced Mallard documents.")
              ;; time of the test suite.
              (setenv "CFLAGS" "-O0")
 
-             (invoke "python" "runtests.py" "-vv"
-                     "-j" (number->string (parallel-job-count))
-                     ;; XXX: On 32-bit architectures, running the parallel tests
-                     ;; fails on many-core systems, see
-                     ;; <https://github.com/cython/cython/issues/2807>.
-                     ,@(if (not (target-64bit?))
-                           '("-x" "run.parallel")
-                           '())
-                     ;; This test fails when running on 24 cores.
-                     "-x" "cpp_stl_conversion"))))))
+             (when tests?
+               (invoke "python" "runtests.py" "-vv"
+                       "-j" (number->string (parallel-job-count))
+                       ;; XXX: On 32-bit architectures, running the parallel tests
+                       ;; fails on many-core systems, see
+                       ;; <https://github.com/cython/cython/issues/2807>.
+                       ,@(if (not (target-64bit?))
+                             '("-x" "run.parallel")
+                             '())
+                       ;; This test fails when running on 24 cores.
+                       "-x" "cpp_stl_conversion")))))))
     (home-page "https://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python