summary refs log tree commit diff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-02-13 11:17:55 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-02-14 17:04:41 +0200
commitc4fca4340343dc1a00c873074185e1902da43477 (patch)
tree8df31f4acfc2bfc05ca3d2b92f8940d125ad461d
parentbf6cd144b482a55f0723835576ed4b7580805972 (diff)
downloadguix-c4fca4340343dc1a00c873074185e1902da43477.tar.gz
gnu: Add rust-protobuf-2.
* gnu/packages/crates-io.scm (rust-protobuf-2): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80f7e619bb..e45263041e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43149,6 +43149,32 @@ language.")
 language.")
     (license license:asl2.0)))
 
+;; It's recommended that rust-protobuf, rust-protobuf-codegen
+;; and rust-probuf-codegen-pure be the same version
+(define-public rust-protobuf-2
+  (package
+    (name "rust-protobuf")
+    (version "2.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "protobuf" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "11bl8hf522s9mbkckivnn9n8s3ss4g41w6jmfdsswmr5adqd71lf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f          ; missing files in the release tarball.
+       #:cargo-inputs
+       (("rust-bytes" ,rust-bytes-0.5)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1))))
+    (home-page "https://github.com/stepancheg/rust-protobuf/")
+    (synopsis "Rust implementation of Google protocol buffers")
+    (description
+     "This package provides a library to read and write protocol buffer's data.")
+    (license license:expat)))
+
 (define-public rust-psl-2
   (package
     (name "rust-psl")