summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 14:00:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:59 -0400
commitd153caabac440073d2123e9ed56151f3da6b3370 (patch)
tree29a72521b82240b27f8cf40bae838cda1570d69e
parent1f88242992346d4e09d959abebb3fc34933bc6b5 (diff)
downloadguix-d153caabac440073d2123e9ed56151f3da6b3370.tar.gz
gnu: Add python-bson.
* gnu/packages/python-xyz.scm (python-bson): New variable.
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d47d9507ba..21b4ac3131 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18400,6 +18400,35 @@ multitouch applications.")
 (define-public python-binwalk
   (deprecated-package "python-binwalk" binwalk))
 
+(define-public python-bson
+  (package
+    (name "python-bson")
+    (version "0.5.10")
+    (source
+     (origin
+       (method git-fetch)               ;for tests
+       (uri (git-reference
+             (url "https://github.com/py-bson/bson")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1vpy4rsvm3hhawvbg9rbw4j36ck8qylkhm8cjy0q6imvinkd2als"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "./test.py")))))))
+    (propagated-inputs (list python-dateutil python-six))
+    (home-page "https://github.com/py-bson/bson")
+    (synopsis "BSON (Binary JSON) codec for Python")
+    (description "@code{bson} is a Python library implementing a BSON (Binary
+JSON) codec.")
+    (license license:asl2.0)))
+
 (define-public python-nltk
   (package
     (name "python-nltk")