summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 22:17:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:57 -0400
commitd9bb301460b77ff2633a8be2fd8a9e600b8371d0 (patch)
tree62b147184ee75281d841ad434321c582a0d49fb7
parentbf17d082566f6c912bc0bd75e3e1791ad2cc7901 (diff)
downloadguix-d9bb301460b77ff2633a8be2fd8a9e600b8371d0.tar.gz
gnu: xeus: Update to 2.4.1.
* gnu/packages/jupyter.scm (xeus): Update to 2.4.1.
[source]: Update Git URI.
-rw-r--r--gnu/packages/jupyter.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 336af2e24a..5bcbd99c24 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -170,15 +170,15 @@ Messaging Protocol}.")
 (define-public xeus
   (package
     (name "xeus")
-    (version "0.23.2")
+    (version "2.4.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/QuantStack/xeus")
+                    (url "https://github.com/jupyter-xeus/xeus")
                     (commit version)))
               (sha256
                (base32
-                "1m1b6z1538r7mv2ggn7bdbd9570ja7cadplq64zl8rgl2c8vdi2a"))
+                "1k1h416qkw3yra6ayfa61nv0v4ify2wvp5x27slgbcw6c88w7fb1"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
@@ -190,7 +190,7 @@ Messaging Protocol}.")
            ;; The following inputs are used by the test suite.
            googletest
            python-pytest
-           python-3
+           python-wrapper
            python-jupyter-kernel-test
            python-jupyter-client))
     (inputs
@@ -199,7 +199,7 @@ Messaging Protocol}.")
            cppzmq
            zeromq
            openssl
-           `(,util-linux "lib")))         ;libuuid
+           `(,util-linux "lib")))       ;libuuid
     (home-page "https://quantstack.net/xeus")
     (synopsis "C++ implementation of the Jupyter Kernel protocol")
     (description