summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-01 06:06:41 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:25 +0200
commitde4ca0934119f61fec4195c69f86d6af31547249 (patch)
tree0e8d03222b1f6efc568b96b33bdc767ffc9c80e8
parent286716f8770f20af18ea0c6802837fa682572cda (diff)
downloadguix-de4ca0934119f61fec4195c69f86d6af31547249.tar.gz
gnu: Add faac.
* gnu/packages/audio.scm (faac): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/audio.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9b29bd19bf..d2ffa54e83 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -128,6 +128,34 @@
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26))
 
+(define-public faac
+  (package
+    (name "faac")
+    (version "1.30")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://sourceforge.net/projects/faac/files/faac-src/"
+                       "faac-1.30/faac-1_30.tar.gz/download"))
+       (sha256
+        (base32 "1lmj0dib3mjp84jhxc5ddvydkzzhb0gfrdh3ikcidjlcb378ghxd"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Freeware Advanced Audio Coder")
+    (description "FAAC is an MPEG-4 and MPEG-2 AAC encoder.")
+    (home-page "https://www.audiocoding.com/faac.html")
+    (license
+     (list
+      ;; ISO MPEG-4 reference code.
+      license:gpl2+
+      ;; Others.
+      license:lgpl2.0+))))
+
 (define-public libtimidity
   (package
     (name "libtimidity")