summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-17 10:57:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-17 12:38:26 +0300
commiteab070a89d9906359ffe0a90c96b74771d836f19 (patch)
treebd28891f02c8ff56afe0c542377996b921aa589e
parente81f26d2c1d3748e06c75d940a395271821474e9 (diff)
downloadguix-eab070a89d9906359ffe0a90c96b74771d836f19.tar.gz
gnu: atop: Update to 2.7.1.
* gnu/packages/admin.scm (atop): Update to 2.7.1.
[arguments]: Remove unnecessary make-flag.  Remove unneeded
substitutions.
-rw-r--r--gnu/packages/admin.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 13c8a2dfd5..34df56d5e7 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4693,21 +4693,19 @@ Netgear devices.")
 (define-public atop
   (package
     (name "atop")
-    (version "2.6.0")
+    (version "2.7.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.atoptool.nl/download/atop-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0wlg0n0h9vwpjp2dcb623jvvqck422jrjpq9mbpzg4hnawxcmhly"))))
+                "0kjwgf94skbrndv1krlmsrq34smzi3iwk73fbsnyw787gvqx4j6a"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no test suite
        #:make-flags
        (list (string-append "CC=" ,(cc-for-target))
-             ;; The installer requires a choice between systemd or SysV.
-             "systemdinstall"
              (string-append "DESTDIR=" (assoc-ref %outputs "out"))
              (string-append "BINPATH=/bin")
              (string-append "SBINPATH=/sbin")
@@ -4722,12 +4720,8 @@ Netgear devices.")
        (modify-phases %standard-phases
          (delete 'configure) ; No ./configure script
          (add-before 'build 'patch-build
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda _
              (substitute* "Makefile"
-               ;; We don't need to chown things in the build environment.
-               (("chown.*$") "")
-               ;; We can't toggle the setuid bit in the build environment.
-               (("chmod 04711") "chmod 0711")
                ;; Otherwise, it creates a blank configuration file as a "default".
                (("touch.*DEFPATH)/atop") "")
                (("chmod.*DEFPATH)/atop") ""))