summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-19 18:45:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-19 18:47:25 +0200
commitf6dbca83bf21b160bcd44d165a683318f6ba8d12 (patch)
tree955b56bda35b31426bc7de1d311f2e7ffcd79fdc
parent8d16f302e69bb61264e51611d7bad1ce7213ab3f (diff)
downloadguix-f6dbca83bf21b160bcd44d165a683318f6ba8d12.tar.gz
gnu: cmake-minimal: Remove some documentation.
These files are still available in the user-facing cmake package.

* gnu/packages/cmake.scm (cmake-minimal)[arguments]: Add phase to remove
help documentation.
-rw-r--r--gnu/packages/cmake.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 5eef3c8488..7e679db220 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -273,6 +273,15 @@ and workspaces that can be used in the compiler environment of your choice.")
        #:phases
        (modify-phases %standard-phases
          ,@%common-build-phases
+         (add-after 'install 'delete-help-documentation
+           (lambda* (#:key outputs #:allow-other-keys)
+             (delete-file-recursively
+               (string-append (assoc-ref outputs "out")
+                              "/share/cmake-"
+                              ,(version-major+minor
+                                 (package-version cmake-bootstrap))
+                              "/Help"))
+             #t))
          (replace 'check
            (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
              (let ((skipped-tests (list ,@%common-disabled-tests
@@ -317,6 +326,7 @@ and workspaces that can be used in the compiler environment of your choice.")
                  ,flags))
        ((#:phases phases)
         `(modify-phases ,phases
+           (delete 'delete-help-documentation)
            (add-after 'install 'move-html-doc
              (lambda* (#:key outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out"))