summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-07-17 11:19:35 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-07-17 15:35:57 +0200
commitfc77c14182aa01d4861914538bfa947868ce3566 (patch)
tree878b8a6923ba6d3658223c11b87eadd86c36da4d
parentc085e707122f49c840dce6e6e12e8515abcb85ed (diff)
downloadguix-fc77c14182aa01d4861914538bfa947868ce3566.tar.gz
gnu: Add sbcl-mcclim-fonts-clx-truetype.
* gnu/packages/lisp-xyz.scm (sbcl-mcclim-fonts-clx-truetype): New variable.
-rw-r--r--gnu/packages/lisp-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d6aebfecb5..9859c8e2ae 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12882,3 +12882,23 @@ specification}, a toolkit for writing GUIs in Common Lisp.")
        ;; Tests want access to user's fonts, which are not available in
        ;; build container.
        #:tests? #f))))
+
+(define-public sbcl-mcclim-fonts-clx-truetype
+  (package
+    (inherit sbcl-clim-lisp)
+    (name "sbcl-mcclim-fonts-clx-truetype")
+    (inputs
+     `(("mcclim-clx" ,sbcl-mcclim-clx)
+       ("mcclim-fonts-truetype" ,sbcl-mcclim-fonts-truetype)
+       ("swank" ,cl-slime-swank))) ; For drei-mcclim
+    (arguments
+     '(#:asd-file "./Extensions/fonts/mcclim-fonts.asd"
+       #:asd-system-name "mcclim-fonts/clx-truetype"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-asd-system-names
+           (lambda _
+             (substitute* "Extensions/fonts/mcclim-fonts.asd"
+               ((":depends-on \\(#:mcclim-fonts/truetype")
+                ":depends-on (#:mcclim-fonts-truetype"))
+             #t)))))))