summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:38:21 +0200
commit0006a664155c7d556ac773b254fd09205412c172 (patch)
tree241a86c6e68d1434afea3227db77cb09d0acd62c
parentc2a18aee16a59330a005bf6818df733a2f56c425 (diff)
downloadguix-0006a664155c7d556ac773b254fd09205412c172.tar.gz
gnu: r-seqlogo: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-seqlogo): Move from here...
* gnu/packages/bioconductor.scm (r-seqlogo): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm23
-rw-r--r--gnu/packages/bioinformatics.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c9f72c5492..b53267e80d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3652,6 +3652,29 @@ differential expression analysis, RNAseq data and related problems.")
     ;; Any version of the LGPL
     (license license:lgpl3+)))
 
+(define-public r-seqlogo
+  (package
+    (name "r-seqlogo")
+    (version "1.56.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "seqLogo" version))
+       (sha256
+        (base32
+         "02rpzjjfg5chlwwfbvv72cm78cg2vfmdwzars0cin9hz1hd7rnq1"))))
+    (properties `((upstream-name . "seqLogo")))
+    (build-system r-build-system)
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/seqLogo")
+    (synopsis "Sequence logos for DNA sequence alignments")
+    (description
+     "seqLogo takes the position weight matrix of a DNA sequence motif and
+plots the corresponding sequence logo as introduced by Schneider and
+Stephens (1990).")
+    (license license:lgpl2.0+)))
+
 (define-public r-seqpattern
   (package
     (name "r-seqpattern")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8f011f0c78..832de0baad 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8023,29 +8023,6 @@ used to obtain robust estimates of the predominant fragment length or
 characteristic tag shift values in these assays.")
     (license license:bsd-3)))
 
-(define-public r-seqlogo
-  (package
-    (name "r-seqlogo")
-    (version "1.56.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "seqLogo" version))
-       (sha256
-        (base32
-         "02rpzjjfg5chlwwfbvv72cm78cg2vfmdwzars0cin9hz1hd7rnq1"))))
-    (properties `((upstream-name . "seqLogo")))
-    (build-system r-build-system)
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page "https://bioconductor.org/packages/seqLogo")
-    (synopsis "Sequence logos for DNA sequence alignments")
-    (description
-     "seqLogo takes the position weight matrix of a DNA sequence motif and
-plots the corresponding sequence logo as introduced by Schneider and
-Stephens (1990).")
-    (license license:lgpl2.0+)))
-
 (define-public r-zlibbioc
   (package
     (name "r-zlibbioc")