summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-11 13:50:38 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-11 13:50:38 +0200
commit0321c098d3d57ae4f046a131a5e9610e3495f843 (patch)
tree23e5de5a3e94ebe500bed2a0e8d5359ac0beafe5
parentabe4bdad800589a84d75903d5b85a1d798a6924a (diff)
downloadguix-0321c098d3d57ae4f046a131a5e9610e3495f843.tar.gz
gnu: kicad: Fix build.
* gnu/packages/engineering.scm (kicad)[arguments]: Add 'fix-python-detection'
  and 'add-missing-include' phases.
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8a1ee88f81..8e9fee6111 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -929,6 +929,16 @@ Emacs).")
                 (string-append "NGSPICE_DLL_FILE=\""
                                (assoc-ref inputs "libngspice")
                                "/lib/libngspice.so\"")))))
+         (add-after 'unpack 'fix-python-detection
+           (lambda _
+             (substitute* "CMakeModules/FindPythonLibs.cmake"
+               (("_PYTHON3_VERSIONS 3\\.8 3\\.7")
+                "_PYTHON3_VERSIONS 3.9 3.8 3.7"))))
+         (add-after 'unpack 'add-missing-include
+           (lambda _
+             (substitute* "common/lib_tree_model.cpp"
+               (("#include <eda_pattern_match.h>" all)
+                (string-append "#include <algorithm>\n" all)))))
          (add-after 'install 'install-translations
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (copy-recursively (assoc-ref inputs "kicad-i18n")