summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-01-10 10:53:20 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-10 11:49:13 +0100
commit04bf1d96344a604c47758da12b21a1ceb1b89178 (patch)
tree381b26b58449c27cf5264c401b763e796e700a60
parent7934e9c55669ebabce3791a9f532188c4ec9eb48 (diff)
downloadguix-04bf1d96344a604c47758da12b21a1ceb1b89178.tar.gz
gnu: gromacs: Remove input labels and use gexps.
* gnu/packages/chemistry.scm (gromacs)[arguments]: Turn into gexps.
[native-inputs]: Remove labels.  Remove (package-source googletest).
-rw-r--r--gnu/packages/chemistry.scm94
1 files changed, 46 insertions, 48 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 33c15dbacc..065d75da6e 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -370,55 +370,53 @@ stored with user-specified precision.")
               (patches (search-patches "gromacs-tinyxml2.patch"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags
-       (list "-DGMX_DEVELOPER_BUILD=on" ; Needed to run tests
-             ;; Unbundling
-             "-DGMX_USE_LMFIT=EXTERNAL"
-             "-DGMX_BUILD_OWN_FFTW=off"
-             "-DGMX_EXTERNAL_BLAS=on"
-             "-DGMX_EXTERNAL_LAPACK=on"
-             "-DGMX_EXTERNAL_TNG=on"
-             "-DGMX_EXTERNAL_ZLIB=on"
-             "-DGMX_EXTERNAL_TINYXML2=on"
-             (string-append "-DTinyXML2_DIR="
-                            (assoc-ref %build-inputs "tinyxml2"))
-             ;; Workaround for cmake/FindSphinx.cmake version parsing that does
-             ;; not understand the guix-wrapped `sphinx-build --version' answer
-             (string-append "-DSPHINX_EXECUTABLE_VERSION="
-                            ,(package-version python-sphinx)))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fixes
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; Still bundled: part of gromacs, source behind registration
-             ;; but free software anyways
-             ;;(delete-file-recursively "src/external/vmd_molfile")
-             ;; Still bundled: threads-based OpenMPI-compatible fallback
-             ;; designed to be bundled like that
-             ;;(delete-file-recursively "src/external/thread_mpi")
-             ;; Unbundling
-             (delete-file-recursively "src/external/lmfit")
-             (delete-file-recursively "src/external/clFFT")
-             (delete-file-recursively "src/external/fftpack")
-             (delete-file-recursively "src/external/build-fftw")
-             (delete-file-recursively "src/external/tng_io")
-             (delete-file-recursively "src/external/tinyxml2")
-             (delete-file-recursively "src/external/googletest")
-             (copy-recursively (assoc-ref inputs "googletest-source")
-                               "src/external/googletest")
-             ;; This test warns about the build host hardware, disable
-             (substitute* "src/gromacs/hardware/tests/hardwaretopology.cpp"
-               (("TEST\\(HardwareTopologyTest, HwlocExecute\\)")
-                "void __guix_disabled()"))
-             #t)))))
+     (list #:configure-flags
+           #~(list "-DGMX_DEVELOPER_BUILD=on"     ; Needed to run tests
+                   ;; Unbundling
+                   "-DGMX_USE_LMFIT=EXTERNAL"
+                   "-DGMX_BUILD_OWN_FFTW=off"
+                   "-DGMX_EXTERNAL_BLAS=on"
+                   "-DGMX_EXTERNAL_LAPACK=on"
+                   "-DGMX_EXTERNAL_TNG=on"
+                   "-DGMX_EXTERNAL_ZLIB=on"
+                   "-DGMX_EXTERNAL_TINYXML2=on"
+                   (string-append "-DTinyXML2_DIR="
+                                  #$(this-package-input "tinyxml2"))
+                   ;; Workaround for cmake/FindSphinx.cmake version parsing that does
+                   ;; not understand the guix-wrapped `sphinx-build --version' answer
+                   (string-append "-DSPHINX_EXECUTABLE_VERSION="
+                                  #$(package-version python-sphinx)))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fixes
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Still bundled: part of gromacs, source behind registration
+                   ;; but free software anyways
+                   ;;(delete-file-recursively "src/external/vmd_molfile")
+                   ;; Still bundled: threads-based OpenMPI-compatible fallback
+                   ;; designed to be bundled like that
+                   ;;(delete-file-recursively "src/external/thread_mpi")
+                   ;; Unbundling
+                   (delete-file-recursively "src/external/lmfit")
+                   (delete-file-recursively "src/external/clFFT")
+                   (delete-file-recursively "src/external/fftpack")
+                   (delete-file-recursively "src/external/build-fftw")
+                   (delete-file-recursively "src/external/tng_io")
+                   (delete-file-recursively "src/external/tinyxml2")
+                   (delete-file-recursively "src/external/googletest")
+                   (copy-recursively #$(package-source googletest)
+                                     "src/external/googletest")
+                   ;; This test warns about the build host hardware, disable
+                   (substitute* "src/gromacs/hardware/tests/hardwaretopology.cpp"
+                     (("TEST\\(HardwareTopologyTest, HwlocExecute\\)")
+                      "void __guix_disabled()")))))))
     (native-inputs
-     `(("doxygen" ,doxygen)
-       ("googletest-source" ,(package-source googletest))
-       ("graphviz" ,graphviz)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python)
-       ("python-pygments" ,python-pygments)
-       ("python-sphinx" ,python-sphinx)))
+     (list doxygen
+           graphviz
+           pkg-config
+           python
+           python-pygments
+           python-sphinx))
     (inputs
      (list fftwf
            `(,hwloc-2 "lib")