summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 16:50:40 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:40 +0100
commit1289001a5d9c41067f9f17c2a361d8850101bdfc (patch)
treebc088f4a4626383148d8a88e822fea4e92d25239
parenta7dc8557257a21cf9bd35f33b0721fe50f7cafef (diff)
downloadguix-1289001a5d9c41067f9f17c2a361d8850101bdfc.tar.gz
gnu: prison: Move to be in alphabetical order.
I was trapped be the definitions not being in alphabetical order.

* gnu/packages/kde-frameworks.scm (prison): Move in front of
  solid.
-rw-r--r--gnu/packages/kde-frameworks.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index b3a7bfdfb4..72dff868cc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1197,6 +1197,31 @@ which are used in DBus communication.")
     (license license:lgpl3+)
     (properties '((upstream-name . "oxygen-icons5")))))
 
+(define-public prison
+  (package
+    (name "prison")
+    (version "5.39.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/frameworks/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32 "1b0ji341xcamrd19z54r2nkm8cglbr4qfxyxmqzn8yc6icfl61nv"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("libdmtx", libdmtx)
+       ("qrencode" ,qrencode)
+       ("qtbase" ,qtbase))) ;; TODO: rethink: nix propagates this
+    (home-page "https://api.kde.org/frameworks/prison/html/index.html")
+    (synopsis "Barcode generation abstraction layer")
+    (description "Prison is a Qt-based barcode abstraction layer/library and
+provides uniform access to generation of barcodes with data.")
+    (license license:lgpl2.1+)))
+
 (define-public solid
   (package
     (name "solid")
@@ -1236,31 +1261,6 @@ querying and interacting with hardware independently of the underlying operating
 system.")
     (license license:lgpl2.1+)))
 
-(define-public prison
-  (package
-    (name "prison")
-    (version "5.39.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://kde/stable/frameworks/"
-                           (version-major+minor version) "/"
-                           name "-" version ".tar.xz"))
-       (sha256
-        (base32 "1b0ji341xcamrd19z54r2nkm8cglbr4qfxyxmqzn8yc6icfl61nv"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)))
-    (inputs
-     `(("libdmtx", libdmtx)
-       ("qrencode" ,qrencode)
-       ("qtbase" ,qtbase))) ;; TODO: rethink: nix propagates this
-    (home-page "https://api.kde.org/frameworks/prison/html/index.html")
-    (synopsis "Barcode generation abstraction layer")
-    (description "Prison is a Qt-based barcode abstraction layer/library and
-provides uniform access to generation of barcodes with data.")
-    (license license:lgpl2.1+)))
-
 (define-public sonnet
   (package
     (name "sonnet")