summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-26 22:10:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-26 22:11:07 +0200
commit182fbbb0094452ffed2bf2984a0d57ca12197265 (patch)
treec6fb420b61212749ec403815ea97a99915245f48
parent00cf71df8046b809beefd3d9fd290777eb2e512e (diff)
downloadguix-182fbbb0094452ffed2bf2984a0d57ca12197265.tar.gz
gnu: python-rapidjson: Update to 1.10.
* gnu/packages/python-web.scm (python-rapidjson): Update to 1.10.
[source]: Simplify snippet.
[arguments]: Run tests conditionally; do not delete test files.
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 770778590d..a466f69963 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6162,17 +6162,17 @@ major web browsers.")
 (define-public python-rapidjson
   (package
     (name "python-rapidjson")
-    (version "0.9.1")
+    (version "1.10")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "python-rapidjson" version))
         (sha256
          (base32
-          "18cl2dhx3gds5vg52jxmh9wjlbiy8dx06c3n482rfpdi9dzbv05d"))
+          "0h1m9m4a5rlf5hw6ak7z3qbgdhmqarzxw9d140mcf7mrxpswpzmc"))
         (modules '((guix build utils)))
         (snippet
-         '(begin (delete-file-recursively "rapidjson") #t))))
+         '(delete-file-recursively "rapidjson"))))
     (build-system python-build-system)
     (arguments
      `(#:configure-flags
@@ -6188,12 +6188,9 @@ major web browsers.")
                                     (assoc-ref %build-inputs "rapidjson")
                                     "/include/rapidjson"))))
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             ;; Some tests are broken.
-             (delete-file "tests/test_base_types.py")
-             (delete-file "tests/test_validator.py")
-             (invoke "python" "-m" "pytest" "tests"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "pytest" "tests")))))))
     (native-inputs
      (list rapidjson python-pytest python-pytz))
     (home-page "https://github.com/python-rapidjson/python-rapidjson")