summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-22 11:20:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-23 20:27:47 +0100
commit2767ee57964f7cc10b83080afb8400f9173bb128 (patch)
treeb3df49cb6ecbd720d9774bcc37438f5441c6706e
parent173a38c6b00fe11fbd0dccf685b2af55a757fbbc (diff)
downloadguix-2767ee57964f7cc10b83080afb8400f9173bb128.tar.gz
gnu: java-icu4j: Update to 70.1.
* gnu/packages/icu4c.scm (java-icu4j): Update to 70.1.
[arguments]: Remove trailing #T from build phases.
-rw-r--r--gnu/packages/icu4c.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index ec526e5ed3..6e70f0c8f6 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -152,7 +152,7 @@ C/C++ part.")
 (define-public java-icu4j
   (package
     (name "java-icu4j")
-    (version "66.1")
+    (version "70.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -162,7 +162,7 @@ C/C++ part.")
                     (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
                     ".tgz"))
               (sha256
-               (base32 "1ahdyz9209lwl7knb2l3gmnkkby221p0vpgx70fj4j02rdzgvw0d"))))
+               (base32 "0qrs75iyzn19kf54q55jn8wf6xjlpkrihdwqpxm39jdh2hz4cgvj"))))
     (build-system ant-build-system)
     (arguments
      `(#:make-flags
@@ -183,22 +183,19 @@ C/C++ part.")
        (modify-phases %standard-phases
          (add-before 'configure 'chdir
            (lambda _
-             (chdir "..")
-             #t))
+             (chdir "..")))
          (add-before 'build 'remove-ivy
            (lambda _
              ;; This target wants to download ivy and use it to download
              ;; junit.
              (substitute* "build.xml"
-               (("depends=\"test-init-junit-dependency\"") ""))
-             #t))
+               (("depends=\"test-init-junit-dependency\"") ""))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((share (string-append (assoc-ref outputs "out")
                                          "/share/java/")))
                (mkdir-p share)
-               (install-file "icu4j.jar" share)
-               #t))))))
+               (install-file "icu4j.jar" share)))))))
     (native-inputs
      (list java-junit java-junitparams java-hamcrest-core))
     (home-page "http://site.icu-project.org/")